Creating a bootbale USB Stick from Xubuntu ISO file on command line (Update)

It took me some research to get this proved instructions to work for any kind of USB Stick and any Linux/ubuntu distro to boot from.

Any usb-creator GUI did not work (for me) and also caused some bugs…

[Current issue at the releases 15.04 and 15.10] There are problems with the Startup Disk Creator alias usb-creator, if you try to create a 15.04 boot drive from the versions 12.04 LTS and 14.04 LTS of Ubuntu. See this link to the release notes https://wiki.ubuntu.com/UtopicUnicorn/ReleaseNotes#Boot.2C_installation_and_post-install. Unetbootin works from Ubuntu 12.04.5 and 14.04.2 (can make a working USB boot drive for Ubuntu 15.04), but the bug is still there in Startup Disk Creator (tested April 29 2015 (and October 22 for 15.10))

Continue reading Creating a bootbale USB Stick from Xubuntu ISO file on command line (Update)

Apple SuperDrive used with Xubuntu

I got a MacBook Air SuperDrive for testing purpose to see if I can write CD-RW on a Laptop with SSD but without CD/DVD drive.

My first thouhgt was nice – it has been recognised by the OS.

kernel: [314896.740912] usb 2-1.1: new high-speed USB device number 18 using ehci-pci
kernel: [314896.919610] usb 2-1.1: New USB device found, idVendor=05ac, idProduct=1500
kernel: [314896.919616] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
kernel: [314896.919619] usb 2-1.1: Product: MacBook Air SuperDrive
kernel: [314896.919622] usb 2-1.1: Manufacturer: Apple Inc.
kernel: [314896.919625] usb 2-1.1: SerialNumber: XYZ         
kernel: [314896.922713] usb-storage 2-1.1:1.0: USB Mass Storage device detected
kernel: [314896.922815] scsi host19: usb-storage 2-1.1:1.0
mtp-probe: checking bus 2, device 18: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1"
mtp-probe: bus: 2, device: 18 was not an MTP device
kernel: [314897.929525] scsi 19:0:0:0: CD-ROM Apple SuperDrive       2.00 PQ: 0 ANSI: 0
kernel: [314897.950652] sr 19:0:0:0: [sr1] scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
kernel: [314897.952286] sr 19:0:0:0: Attached scsi CD-ROM sr1
kernel: [314897.953242] sr 19:0:0:0: Attached scsi generic sg2 type 5

Than I wondered why the SuperDrive does not awake when I tried to put in a blank CD-RW…
Is it really true that Apple does nto want us “normal” users to use their Hardware???

My favourite search engine helped me again and many thanks to Christian Moser who solved it for us!

Cheers

Ubuntix

Show me my system performance with conky

Today I would like to show you my conky system-performance meter. I do use it since the old Ubuntu 13.xx days and I still love it. On top I am very well aware that my conky settings are very basic and show just my needs 😉

How to install conky:

# sudo apt-get install aptitude python-keyring ttf-ubuntu-font-family hddtemp curl lm-sensors conky-all
# apt-get install conky apcupsd audacious xmms2 mpd moc

Customize it to your needs by using the following pages

  • http://conky.sourceforge.net/config_settings.html
  • http://conky.sourceforge.net/variables.html

My conky – config file looks like this:
Continue reading Show me my system performance with conky

Screensaver in Xubuntu 15.10

Till 13.10 Xubuntu uses XScreenSaver as screensaver. In the rare case you installed xfce manually you may want to use

 sudo apt-get install xfce4-settings 

from the universe package to be able to use the settings manager.

In Xubuntu 14.04 onwards light-locker is default and pre-installed.

Light-locker and xscreensaver – to have both is not a good idea see BUG 1304128.

I personally prefer xscreensaver:

# apt-get remove light-locker
# apt-get install xscreensaver xfishtank xdaliclock

Which looks like this …
xfce-xscreensaver

Have Fun!
Ubuntix

Where are my xfce sessions stored?

After upgrading to Xubuntu 15.10 (I should write a section for this experience as well) I got aware of all my old sessions I stored to play around with different auto-start configs.

First question in mind was “Where are those sessions stored?”, second was “How to modify them or remove the ones I don’t need/like anymore?”.

Well, first I remembered about $HOME/.cache/sessions directory – and viola – here they are listed in some cryptic file names…
Anyhow – sorting the output with # ls -ltr you get very easy a clear picture what you should look into more deeper.

xfwm4-26aa58002-86b5..state
xfwm4-2116f077f-59d9..state
xfwm4-29fe00e82-36f8..state
xfce4-session-:0

is the look and feel of my directory.

Either you delete all the files including the thumbs directory or you look inside the -file and delete the lines below [Session: Default|Whateveryournamewas] for each individual session.

Cheers
Ubuntix

How to share foto’s inside my private network? (draft mode)

The idea behind this post was born during Christmas prepare 2015. We wanted to print a photo on the back side of a calendar for 2016 and laminate it.

All we needed was the photo in a specific size on paper. Nothing easier than this, my first thought.
LOL, Yes … how to get the photo from my wife’s windows pc to my Xubuntu and size it with gimp.

here is my work list:
* enable samba share
* secured with user & passwd
* only useable within my private network
* no access from outside
* windows & Linux & mac boxes allowed

Give the default Xubuntu –> Settings –> Share Folders a try…Share_1

Need to change repository?

Hi all,

I got tons of errors during my apt-get update informing me that the repository is currently not available.

Can happen, but after 3 days same message I started to think about to change the repository to a closer / new one.

So I looked around my /etc/apt/sources.list and searched for a way to modify all old repository entries and replace it with the new one.

sed did the trick for me to be honest

sed -i 's/mirror.skylink-datacenter.de/de.archive.ubuntu.com/g' /etc/apt/sources.list

– and I wonder why I do not use it more oft 😉

Cheers
Ubuntix

fsck options after you forget to umount your USB Stick?

Hi all,

As a specialist of “You did forgot to umount your USB Stick” in my virtual machine / local Laptop I always end up with “your USB drive was not unmounted properly”.

    Here is what I do to fix the USB Stick:
  • # lsusb ## need to check if the USB Stick is recognized
  • # df -h ## only one out of many options to check if and where the USB Stick is mounted
  • # fsck -Va /dev/
  • wait and relax – than DO NOT FORGET TO umount YOUR STICK

Cheers

Ubuntix

Windows is a GUI, Unix is an OS

Windows is a GUI, UNIX is an operating system!

By operating system, I mean the complete suite of programs, which make the computer work.
It is stable, multi-user & multi-tasking system for servers, desktops and laptops.

UNIX systems also have a graphical user interface (GUI), which provides an easy to use environment.

There are many different flavours and versions of UNIX. They share common similarities.

One of the most popular flavour of UNIX for me is Sun Solaris, followed by Linux and MacOS X.

How to use gksu in Launcher bar

I was on the way to streamline my desktop and wanted to move some often used helpers to my quick launcher bar.

One of them is my ‘root’-terminal … well, Yes I do want to perform certain actions like fsck and apt-get on cmd-line without ‘sudo’. I know the risk of having a ‘root’-term!

Starting with Alt+F2 and:

gksu 'xterm -e top'

and after the password magically a small xterm with top do pop up.

More for the geeks:

gksu -u root '/usr/bin/xterm -T "root" -bg black -fg green -geometry 140x40'

And now as a launcher in my Quick Launcher bar:

/usr/bin/gksu -u root '/usr/bin/xterm -T "root" -bg black -fg green -geometry 140x40'

tada! it worked …

Have fun
your
Ubuntix